PDA

View Full Version : Annoying Blinker Relay



Dobbo
13-08-2008, 06:27 PM
Does anyone else find their blinker relay quite noisy?
While looking for a rattle the other day in the jack compartment, I found that the relay was just hanging there. After screwing it down with a tek screw it seemed a liitle bit louder. I drove a mates Grande a few weeks ago and his relay sounded to be as loud as what mine is now. I was thinking of maybe wrapping a piece of foam pipe insulation around it to quiet it down.
Anyone else find it a bit annoying :?:

Dobbo

McBAIN
13-08-2008, 06:57 PM
i normally only hear mine when i've got the back seats down for more space, seems to echo a bit more but otherwise doesn't phase me and i rarely hear it unless i'm focusing for it.

craig
13-08-2008, 07:52 PM
Turn the radio up and you won't here the blinker relay :D

Piggy
13-08-2008, 09:23 PM
This was covered in one or two other threads. Wrap it in foam and cable tie it to the thick wiring look in there. Do not solid mount ti to the body with a screw as it amplifies it.

htmon
14-08-2008, 08:42 AM
Yeah I took delivery of my new Grande this monday and i was suprised how loud it was. My mate has an 05prado and he doesnt even have the relays in back. I just wrapped the two relays in some rag and cable tied it.
Cant hear a thing know.

Grey Nomad
15-08-2008, 03:20 PM
Hi all

Another fix is to install a rear drawer unit. Now the front one is too loud!
BTW, only vehicles with a trailer socket have these "slave" relays.

Cheers - John

Dobbo
15-08-2008, 07:17 PM
Thanks guys, I slipped it up inside some foam pipe lagging, quiet as a mouse now :D

clifton
15-08-2008, 08:06 PM
Strewth, Toyota go to all the trouble of making an indicator relay audible for all the bloody idiots that leave them on or do not use them correctly at all and you guys/girls are complaining about a relay that protects your wiring against overload due to some trailers that appear to a circuit as a dead short when connected due to lack of maintenance of the trailer wiring/lighting and your not happy :? :? :?

17-08-2008, 01:21 PM
G'day everyone, I'm new to the forum so hello to all.

While were on the subject of blinker relays, i'v recently taken posession of a new prado with a toyota tow package fitted, and upon hooking up the trailer I noticed that the trailer indicators weren't working.
After some investigating it turns out that there is no power getting to these relays in the jack compartment to supply power to the trailer blinkers.
The relays are being triggered by the vehicle indicator wiring, as they should be, but there is no power present to go through the relay and activate the trailer indicators.
Does anyone know if there is a fuse for this wire or where the power is supposed to come from.
Cheers.

McBAIN
17-08-2008, 03:44 PM
G'day everyone, I'm new to the forum so hello to all.

While were on the subject of blinker relays, i'v recently taken posession of a new prado with a toyota tow package fitted, and upon hooking up the trailer I noticed that the trailer indicators weren't working.
After some investigating it turns out that there is no power getting to these relays in the jack compartment to supply power to the trailer blinkers.
The relays are being triggered by the vehicle indicator wiring, as they should be, but there is no power present to go through the relay and activate the trailer indicators.
Does anyone know if there is a fuse for this wire or where the power is supposed to come from.
Cheers.

G'day Weekender,

welcome aboard! i'd suggest if you've just taken delivery then i'd be heading back to toyota to get them to investigate and fix! could be a dodgy connection on the install

clifton
17-08-2008, 03:59 PM
G'day everyone, I'm new to the forum so hello to all.

While were on the subject of blinker relays, i'v recently taken posession of a new prado with a toyota tow package fitted, and upon hooking up the trailer I noticed that the trailer indicators weren't working.
After some investigating it turns out that there is no power getting to these relays in the jack compartment to supply power to the trailer blinkers.
The relays are being triggered by the vehicle indicator wiring, as they should be, but there is no power present to go through the relay and activate the trailer indicators.
Does anyone know if there is a fuse for this wire or where the power is supposed to come from.
Cheers.
Hi weekender,
Check out this link maybe a fuse missing? http://www.pradopoint.com/viewtopic.php ... ler+wiring (http://www.pradopoint.com/viewtopic.php?t=2956&highlight=trailer+wiring)

20-08-2008, 08:10 PM
Thanks for the replies fellas. I checked for the fuse after reading that previous thread and it turns out that the fuse was not fitted, put a 15amp fuse in and its all good now.
It kind of gives me the sh@ts tho about them not fitting it and makes me wonder what else they haven't done. Great car otherwise tho.